souci d'installation ...

edited novembre 2015 in Le tuto du poivrot
Bonjour à tous/toutes !

Grand débutant sur linux/Raspberry , j'ai voulu tenter l'installation de YANA en suivant le tuto :
https://github.com/ldleman/yana-server
j'ai d'abord installé raspbian sur ma carte ensuite en ssh , j'ai lancé la commande automatique d'installation ....
tout ce passe bien , mais ensuite , je n'arrive pas à me connecter sur la page de yana-server ....
je ne comprends pas ...
merci d'avance
le_belge

Commentaires

  • Bonjour ,

    j'ai beau retourner le problème dans tous les sens ... je ne trouve toujours pas !

    j'ai reformaté ma carte et refais une installation complète et c'est toujours pareil

    erreur 404 ...

    j'ai désactivé mon pare-feu au cas où , mais ça ne change rien ...

    le raspberry est sur le même réseau que mon pc ...

    voili voilou

    le_belge
  • Sérieux , y à personne pour m'aider !!!!

    Au secours !!!!
  • Bonjour ,
    c'est bon problème résolu !

    Merci

    le_belge
  • Hello le_belge, j'ai le même souci que toi, peux-tu me dire comment tu t'en es sorti ?

    Ludo
  • Salut !

    meme probleme, aucune erreur pendant l'execution du script, j'en suis a ma 5e reinstallation de raspbian et toujours le meme soucis. Erreur 404.

    J'ai deja essayé sur un rPI modele B et raspi 2, tout pareil... Je suis en train de devenir chevre ^^

    SOS :)
  • Haha ! 

    finalement j'ai trouvé :) 

    C'est un soucis lié à lighttpd qui ne reconnait pas les sous dossiers (enfin pas toujours, mais des fois oui, mais pour tout le monde... enfin bref...)

    en modifiant le lighttpd.conf, j'ai d'abord eu l'idée de modifier le server.document-root en /var/www/yana-server. Ce qui fait bien le boulot pour une utilisation sous windows vu qu'on peut choisir le chemin du serveur. Sauf qu'une fois sorti mon iphone, je me rends compte qu'on rentre l'ip et basta, l'appli rajoute le chemin /yana-server et on l'a dans le *bip*

    DONC, on modifie a nouveau la ligne server.document-root en "/var/www/"

    et on ajoute une ligne

    dir-listing.activate = "enable"

    Et hop ça marche :D 



  • bon en fait pas besoin d'ajouter la ligne dir-listing activate. Le simple fait de supprimer le html au server document root suffit ;)
  • edited décembre 2015

    j'arrive un peu tard, mais il faut juste créer un lien  symbolique : 

    sudo ln -s /var/www/yana-server /var/www/html
    et redémarrer apache
  • bonjour, j'ai le meme probleme , j'ai voulu tenter l'installation de YANA en suivant le tuto :
    https://github.com/ldleman/yana-server
    j'ai lancé la commande automatique d'installation .... tout ce passe bien , mais ensuite , je n'arrive pas à me connecter sur la page de yana-server ....
    je ne comprends pas ...
    merci d'avance 
Sign In or Register to comment.