YANA, la petite soeur de YURI

15791011

Commentaires

  • @Gregos

    Actuellement, ce n'est pas implémenté.
    Quel serait le but de parler à ton Android ou Windows et faire répondre ta rasp ?

    L'idéal serait de tout avoir sur la rasp, mais aujourd'hui le TTS est à chié
  • @khira Le but est essentiellement d'ecouter des notifications ou alert qui ne sont pas declenchés par un ordre vocal.
  • Salut a tous,
    Je tiens dabord a te feliciter ton blog est une vrai mine d or.....
    Je viens d installer yana windows /et yana sur mon rasp et jusqua la tout vas bien par contre j utilise une kinect sur le windows
    j ai bien la fenetre avec salut je veux parler , je peux t ecouter mais j ai pas de son en retour et dans mon historique j ai bien une ecoute toutes les 5 sec mais le seul mot qu elle entend est cache toi !!

    une idee pour me permettre davancer??

    merci d avance
  • Bonjour a tous,

    je suis entrain de realiser un plugin, enfin j'essai :)

    question bête, j'ai un fichier js avec plusieurs fonctions, comment dois faire pour lancer une fonction a partir de mon plugin?

    Merci
  • Bonjour a tous également 
    Un grand applaudissement pour tous le travail et ton blog,

    Je viens d'installer yana-server et yana-windows, mon probleme c'est que yana ne parle pas et ne reconnais pas ma voix tous comme ROJHIN deux ligne plus haut  cest le bon token vérifier plusieurs fois et meme l'adresse ip quand je me log avec yana-android pas de soucis tous marche.
    sous yana- windows le fichier errors marque tous les cinqs secondes "impossible de parser la réponse "

    Comment traduire cela quelqu'un peut t il m éclairer ?
    Cordialement merci
  • Ceci vient peut être d un plugin, essai d en désactiver un a un. Moi j ai eu le PB avec le plugin mouvement détection.
  • edited septembre 2013
    Bonsoir a tous,
    @byackee  jai desactiver tout les plugins rien y fait , jai bien la reco des comandes dictees dans mon historique
    ma connection win 7 et rasp est nickel ( acces a 192.168.1.2/yana-server depuis windaube)
    je ne sais plus ou chercher

    un coup de main serait le bienvenu
    ps le token est bon!

    merci d avance
  • re,
    Bon j avance;les commandes relance toi, montre toi, cache toi fonctionnent, mais yana toujours muette....
  • moi aussi j ai le meme probleme peut-etre si tu a windows  7 64 bit sa pose probleme avec la reconnaissance vocale de scansoft virginie qui de s'installe pas par default c'est celle en anglais qui reste par default parcontre marche avec windows 7 32 bit voir page 1 du sujet je crois
  • @rojhin et @eliopsys : Aves-vous un message spécifique dans l'historique ? Pour ma part, lorsque les commandes "Montres toi" et "Cache toi" fonctionnent mais pas les autres le problème de parsing venait du fait qu'il y avait un mot inconnu (pour le temps) ou qu'aucun de mes ports GPIO était actif (pour la commande de diagnostic)... donc peut-être que votre problème vient d'une réponse non prévue (surtout si au démarrage YANA vous dit qu'elle entend et peut parler)
  • edited octobre 2013
    Bonjour,

    Je suis utilisateur de SARAH de JP Encausse ET de YANA - je n'arrive toujours pas à faire mon choix !!

    Je déterre un post qui date de la préhistoire pour dire MERCI au posteur du "Ldleman" pour github.

    Et bien sûr merci, et bravo, à Idleman ;)

    Edit :

    J'apprendrai à lire un forum en entier à l'avenir.
  • Bonjour,
    Merci pour ton travail idleman. J'essaie de me servir de Yana pour commander des relais wired, et j'aimerais programmer l'exécution, mais j'ai l'impression que le module "événements" ne permet que d'exécuter des actions sur le client et pas directement sur le PI. Est-ce que je me trompe? Comment pourrais-je faire pour actionner mes relais automatiquement à heures programmées?
    Merci
  • edited novembre 2013
    Je viens de faire la mise à jour mais après reboot du rasp, j'ai ce message sur la page du server:
    Warning: SQLite3::query(): Unable to prepare statement: 1, no such table: yana_rank in /var/www/yana-server/classes/SQLiteEntity.class.php on line 249

    no such table: yana_rank

    Fatal error: Call to a member function fetchArray() on a non-object in /var/www/yana-server/classes/SQLiteEntity.class.php on line 253

    Une idée? Merci

    Bon j'ai appliqué la méthode de base: suppression réinstallation et hop ca marche!
  • Si vous avez ce genre de problème (SQLIte3::query() qui barre en vrille).
    C'est que
    - soit YANA ne sait plus où est la base de données
    - soit que la table n'existe pas dans la base de données

    Dans constant.php l21 on a le chemin de la base de données
    define('DB_NAME','db/database.db');

    On peut aussi fouiller dans la base de données avec un logiciel comme ça

    Dans tout les cas, un truc à ce souvenir:
    TOUT EST SAUVEGARDE DANS CE FICHIER (à part l'état des plugins)
  • edited décembre 2013
    Bonjour,
    même problème que  rojhin .
    Yana marche tres bien sur androide mais elle refuse de parlé sous Windows 7 64 bits (kinect)
    cache toi
    montre toi
    marche
    Donc elle m'entend
    elle m'entend aussi quand je dis allume la lumière du salon mais ne fait rien.
    par contre SARAH marche nickel
    Si rojhin a résolu le problème son aide me serait précieuse.
    D'avance merci

  • Super yana fonctionne parfaitement pour contrôler les lampes sans fils et xbmc. Super aussi la création de plugins.
  • Bonjour à tous,

    J'ai apparemment le même problème que bob25 et rojhin.
    Lorsque je demande à Yana de se cacher, se montrer ou se relancer, tout fonction parfaitement.
    Mais lorsque je lui demande de changer l'état d'un GPIO en disant par exemple allume le salon, rien ne se passe. Pourtant, lorsque je modifie l'état des sorties via un navigateur en cliquant sur les pouces (levé ou baissé) dans l'interface web de Yana serveur, tout fonctionne.
    Dans error.log, elle me marque cette erreur:

    <!> ERREUR: Impossible de parser la réponse: Unexpected character encountered while parsing value: <. Path '', line 2, position 1.

    Je suis sous window 7 32 bit. Le TOKEN est bon, tout comme l'adresse IP du pi. Pour le moment, j'ai gardé Youri en parallèle qui fonctionne nikel. J'avoue ne plus savoir où chercher. Quelqu'un a une idée du problème?

    Merci d'avance.
  • Adama. As tu penser a désactiver et activer les pouvons afin de mettre a jour leur table? Essaye le plugin vocal info et tente de demande l'heure la date ou le temps qu'il fait.9
  • Salut guizzmo merci de ta réponse.

    J'ai réessayé en désactivant les plugins et en les réactivant, mais rien ne veut fonctionner. Même en programmant un événement vocal, il ne se passe rien.
    Par contre l'erreur:

    <!> ERREUR: Impossible de parser la réponse: Unexpected character encountered while parsing value: <. Path '', line 2, position 1.

    Apparaît toute les 5 secondes dans le fichier error. Elle survient à chaque fois que la partie PC tente de contacter la partie serveur. (J'ai vérifié une 34ème fois l'IP et le TOKEN, tout est bon.) J'ai tout désinstallé et j'ai recommencé depuis l'image de raspbian vierge en allant rechercher les paquets officiels... Je suis retombé exactement sur la même erreur. (J'ai aussi réinstallé la partie PC de YANA en reprenant les fichiers sources d'Idle.) Vraiment, là je ne vois pas. Un problème avec le port 80 sur le proxy? Je n'y connais pas grand chose en réseau. Comment fait-on pour vérifier?

    Merci de votre aide
  • Je pense que le problème ne vient pas du côté serveur mais plutôt du client. Je pense que ta une configuration qui doit pas etre la bonne quelque part.
  • Sinon côté client, as tu essayer avec androïde ?
  • Non je n'ai pas encore essayé avec android... Je n'ai pas d'appareil android sous la main.
    Mais si tu penses que le problème vient du serveur, je vais me concentrer de ce côté et je vous tiens au courant.
    Merci de ton aide guizzmo.
  • Je pense que c'est ton microsoft speech coté client qui doit avoir un soucis. En effet, j'ai eu le même problème au début, seul cache toi et montre toi fonctionnait mais ces commandes ont l'air de fonctionner avec autre chose que le reste comme la demande de l'heure.

    Je me souviens avoir réinstaller plusieurs fois et redémarrer etc etc histoire d'être sur d'être bien à jour des composants nécessaire, des voix etc et au bout d'un moment ça a fini par marcher.

    Du coup je peux pas te dire exactement qu'est ce qui manquait mais en tout cas si tu vérifie bien tout plusieurs fois avec reboot et tout et tout, tu devrais arriver à tes fins. Hésite pas a relancer le client si tu pense que celui ci ne réagit plus ou serais en caraffe.
  • Bonsoir tout le monde !

    Je viens de trouver un bug dans Yana For Windows:

    La première fois que j'ouvre l'historique, cela fonctionne. Si je le ferme, et que je cherche à le ré-ouvrir plus tard, j'ai systématiquement un message d'erreur Microsoft .NET Framework: Impossible d'accéder à l'objet supprimé. Nom de l'objet: 'DebugWindow'.

    Avez vous le même souci ?

    Je suis en YANA 1.0.3.

    Merci !
  • Tewis, pareil pour moi j'ai le même problème. Mais comme je n'utilise pas le PC ça ne me gêne pas trop. Mais il arrive de temps en temps que l'interface plante toute seule.
  • Salut,
    Encore merci IdleMan pour ce projet. Tout fonctionne "presque" normalement pour moi.

    Je dis presque car ce qui ne fonctionne pas c'est la fonction "off". Je peux allumer mes équipements soit avec la télécommande d'origine, soit via l'interface web, soit via Yana android. Le hic, c'est qu'ensuite je ne peux plus les éteindre, sauf via la télécommande d'origine.

    j'ai testé en cli directement :

    ./radioEmission 0 1234008 0 on -> OK la lampe s'allume
    ./radioEmission 0 1234008 0 off -> KO il ne se passe rien

    Une idée de ce qu'il faudrait vérifier ?

    Merci

  • Bon bah le forum semble mort... dommage, la solution avait l'air sympa mais elle ne fonctionne pas à 100%. Et sans support, pas évident.

  • effectivement. Le forum est à l'agonie. C'est bien dommage.
  • C'est vrai que je l'ai vu plus vivant que ça !! Mais que fait idle ?? :p
  • Oui c'est vrai que le forum est un peu à l'agonie.
    Pourtant le projet est à mon sens vraiment génial.
    J'ai encore tans de question en suspens et malheureusement très peu de réponse mais compétences sont quasi nul alors je galère vraiment.

    Pour autant je viens de voir une MAJ Yana donc mon enthousiasme reviens.

    J'en profite au passage pour souhaiter une bonne année à toutes les personnes qui me lirons.
Sign In or Register to comment.