impossible de joindre yana server, soucis de port ?

bonjour, apres une install sans "trop" de soucis, tout se termine bien, mais impossible de joindre http://maison.local/yana-server ou avec l'ip.
Je fais un peu de redirect de port sur ma box, ma question est donc : a part le port 80, yana a besoin de quoi ??
Sinon je pense que l'install du stretch raspbian avait un soucis avec lighttpd. Je reinstall sous un raspbian complet ? Je retente ? je laisse tomber et je passe sous une saloperie de google voice/amazon truc ?

Commentaires

  • hmmm a l install il me dit que lighttpd n'est pas installé. Je l'install et arrive a le voir avec un navigateur mais apres l'install de yana, ça ne marche plus... je fouille

  • salut 
    tu as installer lighttpd  comment manuellement?
  • oui manuellement

  • en fait l install de yana me dit qu'il n y est pas, alors j'ai recommencé en installant lighttpd manuellement.
    La je retente sur un raspbian complet, j'install lighttp, php et mysql a la main, ensuite je lance l'install de yana... on verra bien

  • esseye un sudo /etc/init.d/lighttpd force-reload en plus

  • ok je vais tenter ça, merci.
    Je suis helas a deux doigts et demi de laisser tomber et ça me désole...

  • oui je te comprend je suis dans le meme cas que toi
    je viens de le ressortir du grenier pour jouer avec mais c est galère....

  • bon et bien ça ne marche clairement pas en faisant toute l'install a la main... je retente une fois de zero et apres tant pis.

  • voila exactement ce que j'ai fait avec un 2017-09-07-raspbian-stretch-lite.img

    sur le rasp en direct :
    redim partition
    sudo reboot
    permettre ssh
    reboot



    en ssh :

    sudo apt-get update
    sudo apt-get dist-upgrade
    sudo rpi-update
    sudo reboot

    sudo aptitude update
     sudo aptitude upgrade

    sudo aptitude install apache2

    sudo reboot

    verif sous navigateur --> ok


    sudo chown -R pi:www-data /var/www/html/
    sudo chmod -R 770 /var/www/html/

    sudo aptitude install php7.0

    sudo reboot

    verif sous navigateur si apache toujours ok --> ok

    sudo apt-get install sqlite3

    sudo reboot

    verif sous navigateur si apache toujours ok --> ok

    curl -L yana.madnerd.org|sudo bash

    non a redim
    non a lighttpd

    verif sous navigateur si apache toujours ok --> ok

    ip +/yana-server --> KO
    maison.local/yana-server/ --> KO

    ctrl +c sur le ssh


    sudo ln -s /var/www/yana-server /var/www/html
    sudo reboot

    verif sous navigateur si apache toujours ok --> ok

    ip +/yana-server --> Fatal error: Uncaught Error: Call to undefined function mb_internal_encoding() in /var/www/yana-server/common.php:17 Stack trace: #0 /var/www/yana-server/header.php(2): require_once() #1 /var/www/yana-server/index.php(2): require_once('/var/www/yana-s...') #2 {main} thrown in /var/www/yana-server/common.php on line 17
  • sudo apt-get install php7.0-mbstring

    sudo reboot

    ip +/yana-server --> enfin une page yana !! Mais

    Warning: include(classes/SQLite3.class.php): failed to open stream: No such file or directory in /var/www/yana-server/install.php on line 16

    Warning: include(): Failed opening 'classes/SQLite3.class.php' for inclusion (include_path='.:/usr/share/php') in /var/www/yana-server/install.php on line 16
    error: Le pré-requis SQLITE3 n'est pas installé.
    Pour résoudre ce problème, merci de taper la commande suivante dans le shell sudo apt-get install sqlite3 php5-sqlite
    warning: Le chemin de l'executable de wiring pi est à modifier dans classes/Gpio.class.php, remplacer /usr/bin/gpio par /usr/local/bin/gpio.

    sudo apt-get install sqlite3 php5-sqlite --> ko (normal)
    sudo apt-get install php7.0-sqlite3
    sudo reboot

    ip +/yana-server --> il est content mais dit : warning: Le chemin de l'executable de wiring pi est à modifier dans classes/Gpio.class.php, remplacer /usr/bin/gpio par /usr/local/bin/gpio.

    pas grave j'utilise pas le gpio du pi

    ET ENFIN LA BONNE PAGE EST LA !!


  • je confirme que ça marche !!! Je suis joie !
    Comment passer le post en resolu ?
  • bien c ete quoi le soucie

  • ajout de la lib php zip pour installer les plugin:
    en ssh :
    sudo apt-get install php7.0-zip<br>sudo reboot<br>
  • en fait je ne sais pas exactement ou était le soucis... a mon avis lighttpd a changé de version et provoquait des erreurs... du coup sous apache ça marche mieux.
    Bon la j'ai un soucis de commande vocal... je continue a debug tout ça !!
  • wé j ai eu le meme probleme que toi

    faut que je regle encore les gpio cet aprem
  • eeet je viens de planter le truc en activant deux fois la commande vocal....
    bon ben hein !! voila --> go to trash

  • ca va tu as reprit connaissance  b-(
Sign In or Register to comment.