Allumer les prises à distance tuto 12

Salut,

Je touche presque au but, ça fait un moment que je suis sur les différents tuto (pas à plein temps) mais je m'éclate bien à bidouiller.
J'ai un problème dont je ne comprends rien du tout (comme à chaque étape).  
J'ai tout suivi les branchement tout va bien, la programmation c'était un peu bizarre pour la dernière ligne de commande, ça ne marché pas j'avais comme réponse qu'aucun fichier n existé, j'ai donc fais ceci :  sudo chmod 4777 /var/www/hcc/radioEmission

Je pensé touché au but, je me connecte comme il faut à l'interface web, j'ai jamais été aussi heureux de voir un ventilo et un lapin.
Mais rien ne marche, la prise ne se synchronise pas (dans le tuto il dit depuis l'interface web j'ai trop pigé ou), j'ai donc tenté une ligne de commande /var/www/hcc/radioEmission 0 12325261 1 on,    voici la réponse 
sh: 1: /etc/lcd/screen: not found

Voilà je nage grave merci de m'aider (j'ai oublié de préciser je débute avec Linux, je viens de très loin) MERCI D'AVANCE

Commentaires

  • Allez les geeks je suis que quelqun a une idée
  • bilbil
    edited novembre 2016
    Salut
    Dans les commentaires du tuto 12 idleman répond a ta question

    j’ai le message d’erreur suivant lorsque je commande ma prise en ligne de commande :

    pi@raspberrypi /var/www/hcc $ sudo ./radioEmission 0 8217034 0 on

    sh: 1: /etc/lcd/screen: not found

    le répertoire lcd n’existe pas???? sinon le relais s’enclenche bien.

    j’ai fait ce que tu m’a dit pour la commande web et ça ne marche tjs pas. Peut-être à cause de ce répertoire lcd ???

    qu’en penses-tu ?

    merci

    Reponse d'idleman :

    Non ca c’est parce que mon programme affiche aussi l’envoie du signal
    sur l’écran lcd du tuto 11, donc si tu ne l’a pas fait ça t’affiche un
    petit warning mais ça n’influe pas sur le reste.

    pour l’interface web il doit se passer quelque chose au niveau des
    permissions, as tu bien fait le chmod 777 sur radioEmission ?

    regarde ce qu’il y a dans le fichier /var/log/apache2/error.log juste après la manip

    Voila ,rassure toi c'est normal,Moi aussi j ai un peu ramer au début et je dois dire que la lecture des commentaires m'a beaucoup aider.
    A+
  • Merci pour ta réponse. Jai un peu lâche le truc par manque de temps mais des que j'ai un moment je me penche dessus, je vais aller voir les commentaires.
  • edited novembre 2016

Sign In or Register to comment.